Snejportal

D2 Lunatics Realm (D2L) (online) => General => Support => Topic started by: Racer on December 07, 2014, 01:28:44 PM

Title: unable to identify version
Post by: Racer on December 07, 2014, 01:28:44 PM
Hey,


jedes mal wenn ich versuche ins bnet (d2 Lunatics) zu kommen, bekomme ich einen Fehler mit "unable to identify version". Kann mir da jemand helfen?


Ich habe schon alles deinstalliert, Diablo neu installiert, LOD neu installiert dann Update auf 1.13c und 1.13d gemacht, dann d2se installiert, dann snej. Aber immer noch das gleiche Problem. Ich kam am Anfang auch im normalen game nicht ins bnet bis ich vorher das Update auf 1.13d gemacht habe. Dies funktioniert jetzt aber. Ich habe auch probiert alle Dlls aus dem 1.13c core ordner in mein Diablo Verzeichnis zu kopieren. Leider auch ohne Erfolg.


everytime i try to connect to bnet (d2 Lunatics) i get a failure text with "unable to identify version". Can someone help me with that?


greetz


Racer
Title: Re: unable to identify version
Post by: Merlin Peh on December 07, 2014, 01:32:14 PM
Hast du Snejversion 6.0.06 und Diablo2core 1.11b sowie in der Setup.ini alles geändert?
Title: Re: unable to identify version
Post by: Seltsamuel on December 07, 2014, 01:51:09 PM
Das ist sehr eigenartig .. denn eigentlich habe ich die Versionchecks komplett deaktiviert da D2 sonst immer die Dateien aus dem haupt D2 Verzeichnis dafür heranzieht.

Die Realm läuft nur mit Snej 6.0.0.6 das ist aber installiert ?
In der D2SE_SETUP.ini ist die Realm angepasst wie in meinem Post beschrieben?

Versuche mal die Dateien aus der 1.11b CORE in Dein D2 Hauptverzeichnis zu kopieren..

Wenn die gröbsten Probleme beseitigt sind werde ich mit Hochdruck an der neuen D2SE Version arbeiten die das Problem auf die richtige Art lösen sollte.

Gruß

Seltsamuel
Title: Re: unable to identify version
Post by: Racer on December 07, 2014, 01:56:12 PM
ich habe jetzt alle .dll aus dem 1.11b core drin. Snej Version 6.0.06Pre2. Geht leider immer noch nicht.


Ich war da aber jetzt auch schon auf Version 1.11c, könnte das ein Problem sein?
Title: Re: unable to identify version
Post by: Seltsamuel on December 07, 2014, 02:11:10 PM
Ich sehe grade das im CORE ja nicht die game.exe der jeweiligen version liegt ..
Hast Du ne Möglichkeit die von 1.11b ebenfalls ins D2 mainverzeichnis zu legen ?

Ich versuche mal was in den logs zu sehen.. da aber alle anderen damit kein problem haben ist das schon eigenartig.

Gruß

Seltsamuel

Title: Re: unable to identify version
Post by: Racer on December 07, 2014, 02:26:35 PM
ich könnte neu installieren und dann versuchen von d2 die 1.11b core von der HP zu installieren, wenn das Hilft.?
Title: Re: unable to identify version
Post by: Seltsamuel on December 07, 2014, 02:31:10 PM
sollte eigentlich..
Title: Re: unable to identify version
Post by: Racer on December 07, 2014, 03:03:11 PM
Ich kann leider nicht mit dem patcher auf 1.11b weil von haus aus schon eine neuere Version installiert ist. Habe es jetzt noch mal mit dem core aus 1.11b probiert. Hilft aber nicht.


Mir gehen da langsam die Ideen aus, früher ging das alles doch noch :/ Hab Win 8 falls das hilft.
Title: Re: unable to identify version
Post by: Zerum on December 07, 2014, 03:54:52 PM
Hi,
hast du denn die D2SE_SETUP.ini auch angepasst?
http://snej.org/forum/index.php?topic=44254.msg757234#msg757234 (http://snej.org/forum/index.php?topic=44254.msg757234#msg757234)
Du sagst zwar D2Lunatics aber besser ist man fragt mal nach  :)
Title: Re: unable to identify version
Post by: Racer on December 07, 2014, 04:00:31 PM
jo hab ich, das steht drin :



RealmGateway=77.232.77.130
RealmTimezone=-1
RealmGatewayName=D2 Lunatics
RealmSelected=SnEj
RealmPort=4358
Title: Re: unable to identify version
Post by: Zerum on December 07, 2014, 04:03:05 PM
und sonst nichts?
Title: Re: unable to identify version
Post by: Racer on December 07, 2014, 04:12:43 PM
doch klar, aber das sind die Zeilen mit dem neuen Realm die ich kopiert hab, der Rest ist ja unverändert
Title: Re: unable to identify version
Post by: Seltsamuel on December 07, 2014, 04:15:24 PM
hier die 1.11b game.exe:

http://www.d2se.org/d2se/Game.exe
Title: Re: unable to identify version
Post by: Racer on December 07, 2014, 04:24:55 PM
danke, habs eingefügt. Leider ohne Erfolg.
Title: Re: unable to identify version
Post by: Seltsamuel on December 07, 2014, 04:38:57 PM
Hi,

versuch nochmal zu verbinden ..
danach kopiere mir mal den inhalt deiner ./MODS/Snej60/BnetLog.txt in einen post.

Da hast zufällig nicht vorher mal einen Gatewayeditor benutzt ?
Wenn ja mußt Du mit diesem die realmip ändern da einige gatewayeditoren einstellungen so ablegen das D2SE sie nicht überschreiben kann.

Gruß

Seltsamuel
Title: Re: unable to identify version
Post by: Racer on December 07, 2014, 04:49:24 PM
Ich hatte schon ewig keinen mehr, hatte ihn auch gelöscht und dia 100 mal neu installiert. Hab mir den jetzt wieder geholt, d2 lunatics eingetragen - und siehe da es geht. Danke! :)
Title: Re: unable to identify version
Post by: Seltsamuel on December 07, 2014, 05:07:28 PM
ja denn wo auch immer du hinconnectest  Connected to server 88.198.17.132 D2 Lunatics ist 77.232.77.130

Also mal in der Registry die ip suchen und ersetzen .. am besten hier nochmal pasten wo überall die andere ip steht!
Title: Re: unable to identify version
Post by: Racer on December 07, 2014, 05:08:15 PM
Ich hatte schon ewig keinen mehr, hatte ihn auch gelöscht und dia 100 mal neu installiert. Hab mir den jetzt wieder geholt, d2 lunatics eingetragen - und siehe da es geht. Danke! [/size][/color]
Title: Re: unable to identify version
Post by: der Jack on December 07, 2014, 05:11:08 PM
Bei mir genauso...
Dabei hatte ich den meines Wissens nach nur für WC3 benutzt.
Egal, tut's ja jetzt.
Title: Re: unable to identify version
Post by: Seltsamuel on December 07, 2014, 07:17:16 PM
Bitte schreibt mir mal alle stellen wo die falsche IP in der registry stand!

Denn ich möchte das mit der nächsten D2SE Version so machen das er den Mist mitfixt.

Gruß

Seltsamuel

Title: Re: unable to identify version
Post by: der Jack on December 07, 2014, 09:03:58 PM
Kann ich dir gar nicht genau sagen. Hab einfach den Gateway-Editor benutzt, der hat's dann korrigiert. :/
Title: Re: unable to identify version
Post by: Seltsamuel on December 08, 2014, 12:37:51 AM
Dann mal regeditor aufmachen und mir sagen wo du überall die IP 77.232.77.130 jetzt findest ;-)

Ziel ist es D2SE so zu ändern das es die Fehler anderer Programme mitausbügeln kann ud es nicht mehr zu den genannten Problemen kommen kann.

Gruß

Seltsamuel
Title: Re: unable to identify version
Post by: der Jack on December 08, 2014, 12:44:26 AM
Per Regedit-Suche nur an dieser Stelle:
HKEY_CURRENT_USER -> Software -> Blizzard Entertainment -> Diablo II -> BNETIP
Title: Re: unable to identify version
Post by: Seltsamuel on December 08, 2014, 12:54:00 AM
danke welchen editor hast du benutzt? ist das auch der den du immer benutzt hast? url?

Ggf setzt er das teil auch einfach auf schreibgeschützt, muss mir das mal selber ansehen.

Gruß

Seltsamuel
Title: Re: unable to identify version
Post by: der Jack on December 08, 2014, 11:31:49 PM
Den Blizzard Battle.net Gateway Editor (http://www.icyhell.net/2008/05/06/blizzard-battlenet-gateway-editor-v3010702/) von Icyhell.net.
Title: Re: unable to identify version
Post by: Seltsamuel on December 09, 2014, 12:33:44 AM
Hi,

danke den schau ich mir mal an.

Gruß

Seltsamuel