gfx gfx
gfx gfx
Please login or register.

Login with username, password and session length
gfx gfx
gfx gfx

  • Welcome at our new home!!!

    This is the Snej Portal, home of several D2 Modifications and D2SE
  • On our Realmserver you can find this hosted Mods:

    Snej
    Reign of Shadows (RoS)
    Eastern Sun (ES)
  • You can also find the home of the

    Aftermath Mod here

    http://snej.org/forum/index.php?board=674.0
gfx gfx
gfx
May 21, 2018, 01:16:33 PM
*
gfx gfx
gfx* Home Help Search Login Registergfx

Author Topic: D2SE Modmanager V2.3 Announcement & Patchlog  (Read 70371 times)

0 Members and 1 Guest are viewing this topic.

Offline SeltsamuelTopic starter

  • Administrator
  • Duriel
  • **
  • Posts: 1820
  • Gender: Male
    • Snej-Mod Homepage
Re: D2SE Modmanager V2.3 Announcement & Patchlog
« Reply #60 on: January 31, 2016, 05:48:34 PM »
Hi,

at the moment work on my projects has stopped due lack of time. This will hopefully change soon. Regarding the versions.. D2SE will always be downwards compatible and the Mod will use the Version that is set inside the .ini file. So if you want that the Mod runs under 1.13d the modder / creator of the plugin has to set it inside the specific D2SE_SETUP.ini to use 1.13d.. anything else would not make sense.

Greetings

Seltsamuel

Offline Untamed

  • Little Pickpocket
  • *
  • Posts: 2
Re: D2SE Modmanager V2.3 Announcement & Patchlog
« Reply #61 on: February 24, 2016, 08:59:58 PM »
Your tool is amazing. I've just discovered it yesterday trying to get some D2 nostalgia back!

I just wanted to share with you this image, I'm not sure you're aware of the problem.

It's a bit ugly, but everything works 100% so it's not a big deal, but I think this is related to DPI scaling. I'm on a 3k screen, so I require it but sometimes it isn't pretty lol

Cheers and best of luck IRL :D


Offline SpiKe.

  • Global Moderator
  • Web Mage the Burning
  • *
  • Posts: 334
  • Gender: Male
    • Reign of Shadow
Re: D2SE Modmanager V2.3 Announcement & Patchlog
« Reply #62 on: February 24, 2016, 10:37:18 PM »
You are using Windows 10 or? There is an option to turn off dpi-scaling in windows...
Seltsamuel explained how to change it http://snej.org/forum/index.php?topic=18834.0
« Last Edit: February 24, 2016, 11:01:18 PM by SpiKe. »

Offline Untamed

  • Little Pickpocket
  • *
  • Posts: 2
Re: D2SE Modmanager V2.3 Announcement & Patchlog
« Reply #63 on: February 25, 2016, 03:40:57 AM »
I'm using Windows 7, so it's not as easy as Windows 10 to fix individual DPI and unfortunately I do need to use a higher DPI as my screen is 2880x1620. :(

As I said, it works fine so it's not a big deal, I just registered to share knowledge. :)

Sorry for not noticing the other thread! I should pay attention better lol

Cheers

Offline LordNyriox

  • Little Pickpocket
  • *
  • Posts: 5
Re: D2SE Modmanager V2.3 Announcement & Patchlog
« Reply #64 on: June 08, 2016, 01:23:47 AM »
Hi Seltsamuel!

I don't know what the status is on your PlugY porting process is, but I thought you might want to know that a community-made update of PlugY to support Diablo II 1.13d can be found at <
https://github.com/ChaosMarc/PlugY
> (for the Github repository).  See <http://d2mods.info/forum/viewtopic.php?f=133&t=62849> for more details. 

Note, however, that Diablo II v1.14 (a or b) have not yet had their support fixed. 
The biggest change in Diablo II v1.14 as far as modding goes seems to be that every .dll file in the game has been merged directly into game.exe, just so you know. 

Thanks,
– Nyriox


Offline bluechimera

  • Witch Doctor Endugu
  • **
  • Posts: 355
  • Gender: Male
  • All who oppose me... beware
Re: D2SE Modmanager V2.3 Announcement & Patchlog
« Reply #65 on: June 09, 2016, 07:37:10 AM »
Awesome, thanks for sharing this! :)
Wherever you go... There you are!

Offline SeltsamuelTopic starter

  • Administrator
  • Duriel
  • **
  • Posts: 1820
  • Gender: Male
    • Snej-Mod Homepage
Re: D2SE Modmanager V2.3 Announcement & Patchlog
« Reply #66 on: July 02, 2016, 07:50:36 PM »
Hi,

thx for the info. Usually ill keep watching the PK board myself but i was nearly 2 month without telephone and internet now .. so i have to work through all the news now.

Greetings

Seltsamuel

Offline Thor3255

  • Little Pickpocket
  • *
  • Posts: 2
Re: D2SE Modmanager V2.3 Announcement & Patchlog
« Reply #67 on: August 22, 2016, 02:23:05 PM »
Hi,
i have a problem with this running on my pc. I hope anyone can tell me how to get it going again.

I used this tool with my old cd's and it worked fine. After a new windows installation i downloaded the actual version of blizzard... fast and easy install, no need of compatibility mod (using win 7) BUT i cant play with this  :(

the installation of D2SE worked fine, but when i want to start the game, choosing the patch version a error window pops up, saying:
the file data is corrupt.
file: .....\diablo II\d2data.mpq

i hope there is a solution for this problem someone can tell me. i dont want to install the old version (the cd's)  :-[
maybe there is just a little change needed of the modmanager? if this doesnt work i need to re-install it.

thanks and sry for my bad english

Offline SpiKe.

  • Global Moderator
  • Web Mage the Burning
  • *
  • Posts: 334
  • Gender: Male
    • Reign of Shadow
Re: D2SE Modmanager V2.3 Announcement & Patchlog
« Reply #68 on: August 22, 2016, 03:37:06 PM »
Hi,

D2SE doesn't work with patch 1.14 for now due to some heavy changes regarding to the .mpq files.
To fix this you have to download an older Version (u can find it somewhere here in the forum) or install it from cd's. Afterwards patch it to 1.13c. If u then install D2SE, it should work without any problems. (Downgrading from 1.14 to 1.13 doesn't work!)

Seltsamuel is about to fix it, so it will work with 1.14. Due to lack of time, it can take abit ;)

Greetings
Spike.

Offline Thor3255

  • Little Pickpocket
  • *
  • Posts: 2
Re: D2SE Modmanager V2.3 Announcement & Patchlog
« Reply #69 on: August 22, 2016, 06:12:30 PM »
great
 
i downloaded a 1.12 version and everything is just fine  ;D


big thx

Offline Garnithron

  • Little Pickpocket
  • *
  • Posts: 1
Re: D2SE Modmanager V2.3 Announcement & Patchlog
« Reply #70 on: January 01, 2017, 07:10:49 AM »
Hello!

I registered here only to thank you very much Seltsamuel for your job. I was playing Diablo II a lot of time and always wanted to have some program that will give me some control of mods and versions of Diablo II. It is worth to download some older versions of D2, install D2SE and play with the Survival Kit plugin. My brother recently had bought three original copies of D2: LoD to play legally on B.Net and don't care of creating virtual LAN connection. Few months ago i've created my first hell-playable self-find character (blizz- sorc) and i was playing using your modmanager. I've found a lot of items and runes and everything was going perfectly. I'm going to persuade him to throw away that B.Net with random bans for creating multiple games in short period of time and start with me on plugy. But he is not acquainted with all that mess including downloading other versions, installing, creating LAN connection etc. So, i thought that it will be cool if we could install D2SE on 1.14d version of Diablo 2, but i've heard, that there are some changes in *. mpq files starting with 1.14 so it isn't such easy to make D2SE compatible with newest version, frankly. Thanks once again for all your job!

I have one question lastly. Are you planning to release new version of D2SE that will work with B.Net release (1.14d)?

Garnithron

Offline SeltsamuelTopic starter

  • Administrator
  • Duriel
  • **
  • Posts: 1820
  • Gender: Male
    • Snej-Mod Homepage
Re: D2SE Modmanager V2.3 Announcement & Patchlog
« Reply #71 on: January 02, 2017, 01:10:48 PM »
Hi Garnithron,

thanks for your Heads up.
Yes im actually working on 1.14d support for D2SE and sadly this is more work than expected as blizzards programmer did a real mess there.
1.13d Support is already finished and working, additinally D2SE gets a complete new UI System to avoid Microsofts compatibility issues with high DPI between different Windows versions, this is still not 100% finished too.

As soon as i have release ready stuff ill announce it.

Greetings

Seltsamuel

Offline AlphA

  • The Summoner
  • *****
  • Posts: 273
Re: D2SE Modmanager V2.3 Announcement & Patchlog
« Reply #72 on: January 23, 2017, 04:48:34 PM »
Did anyone tried the newest plugy version with D2SE yet? Yohann released it yesterday.

Cheers
AlphA

Offline bluechimera

  • Witch Doctor Endugu
  • **
  • Posts: 355
  • Gender: Male
  • All who oppose me... beware
Re: D2SE Modmanager V2.3 Announcement & Patchlog
« Reply #73 on: January 24, 2017, 02:34:13 PM »
I tried plugy 11 with ES and it crashes C000005 
no time to mess with it right now in order to fix (if I can), though
Wherever you go... There you are!

Offline SpiKe.

  • Global Moderator
  • Web Mage the Burning
  • *
  • Posts: 334
  • Gender: Male
    • Reign of Shadow
Re: D2SE Modmanager V2.3 Announcement & Patchlog
« Reply #74 on: January 24, 2017, 03:57:28 PM »
Plugy 10/11 doesnt support 1.10.

Offline bluechimera

  • Witch Doctor Endugu
  • **
  • Posts: 355
  • Gender: Male
  • All who oppose me... beware
Re: D2SE Modmanager V2.3 Announcement & Patchlog
« Reply #75 on: January 25, 2017, 08:10:43 AM »
Ah yes, that must be it.
Sorry, I have not played much of any D2 mods lately.

I also just tried Perfect Drop Mod, and classic D2 1.13C in D2SE with same error :(
« Last Edit: January 25, 2017, 01:49:29 PM by bluechimera »
Wherever you go... There you are!

Offline ChaosMarc

  • Global Moderator
  • Boneash
  • *****
  • Posts: 55
  • Gender: Male
Re: D2SE Modmanager V2.3 Announcement & Patchlog
« Reply #76 on: January 29, 2017, 12:01:25 PM »
Plugy 10/11 doesnt support 1.10.

thats not true, spike:



All new features like char & stashpage renaming, the new runeword page etc. are working perfectly (windows 10). what makes you say that it doesn't?


PlugY v11.00 worked with D2SE (though not with 1.13d, as there is no core for it) if you replaced all files in "..\Diablo II\PlugY\" with the ones from PlugY v11.00. Sadly this does not work with v11.01 any more. A c000005 error is displayed and no log files are created but a Crashdump file
« Last Edit: January 29, 2017, 12:37:26 PM by ChaosMarc »

Offline SpiKe.

  • Global Moderator
  • Web Mage the Burning
  • *
  • Posts: 334
  • Gender: Male
    • Reign of Shadow
Re: D2SE Modmanager V2.3 Announcement & Patchlog
« Reply #77 on: January 29, 2017, 01:01:14 PM »
Plugy 10 is bugged with 1.10, atleast if u are running it with a realm and Plugy 11 should be the same.
Of course it runs but as far as i know it can cause severeal crashes.

Offline bluechimera

  • Witch Doctor Endugu
  • **
  • Posts: 355
  • Gender: Male
  • All who oppose me... beware
Re: D2SE Modmanager V2.3 Announcement & Patchlog
« Reply #78 on: February 15, 2017, 04:36:59 PM »
Selts,
Do you plan to release the next version of D2SE this decade?
I recall asking this in Dec 2013 and you said you were close then and was planning a release around Christmas of that year... nothing came though.
I am just poking , but lately, I only come to this site to see if there is any new D2SE, or if there are any new mod releases... everything else is just new accounts, or in German so I clear it from my "Unread" posts by opening it and skipping back to "read" the next one.


Just curious about the progress, hopefully not the same tune you have been singing for last 3+ years, though.


Thanks :)
Wherever you go... There you are!

Offline SeltsamuelTopic starter

  • Administrator
  • Duriel
  • **
  • Posts: 1820
  • Gender: Male
    • Snej-Mod Homepage
Re: D2SE Modmanager V2.3 Announcement & Patchlog
« Reply #79 on: February 15, 2017, 07:08:30 PM »
Hi,

yes im still working on it as the release of the 1.14x series of D2 patches introduced a big bunch of new and heavy problems.
Maybe someone should tell blizzard to stop development and release of senseless patches. Sadly at least i have to support 1.14d.

Greetings

Seltsamuel

Snejportal  |  D2SE  |  D2SE Modmanager  |  Topic: D2SE Modmanager V2.3 Announcement & Patchlog
 

gfxgfx
gfx
SMF 2.0.10 | SMF © 2015, Simple Machines  Snejtheme V2 by Seltsamuel/Faust (based on Helios Multi by Bloc)
gfx